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Abstract — This article in short introduces TeXstudio editor, which ease creation of scientific and 

mathematical documents in program LaTeX. This editor is due to its simplicity and helpful community, 

suitable mainly for beginners, who do not have any or very low experience with LaTeX.  
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I. INTRODUCTION 

TeX (/ˈtɛx/ or /ˈtɛk/) is computer program, which author is Donald E. Knuth, and which is suitable 

for producing scientific and mathematical documents of high typographical quality [1]. In contrast to 

classical WYSIWYG (What you see is what you get) editors like MS Word, TeX is. WYWIWYG 

editor (What you want is what you get). Thus author is not able to see final output while typing text in 

to the computer. Output is visible after processing file with TeX.  

LaTex is built on TeX, but is more simplified then classical TeX, to be more user friendly. LaTeX is 

set of prearranged macros, that ease work with TeX [2]. 

In present LaTeX become more popular because of elaborated editors. These editors ease and in 

most of cases speed up work by predefined commands, tables, etc. Most popular editors are for 

example TeXstudio, TeXmaker or TeXworks. Then there are also online editors like ShareLaTeX or 

Overleaf. These provide creation of LaTeX documents directly in web browser. Output then can be 

easily downloaded to PC or uploaded to some of the clouds. 

This article provides very brief introduction to creating and editing of documents in TeXstudio 

editor, which works on platform MS Windows. The goal of this paper is not to explain work with 

LaTeX in detail, but ease LaTeX mainly to users of WYSIWG editors, by user friend interface of 

TeXstudio. 

II. INSTALLATION AND FIRST SETUP  

Before the installation of editor is firstly important to install one of the distributions of TeX. Most 

popular distribution for MS Windows is MiKTeX which is able to download at webpage [3]. In case 

of multiplatform distributions is probably most popular TeXLive. It is available on project web site 

[4]. Installation itself is quite simple and it does not differ from installation of other common software. 

Thus we will not have to dedicate it more deeply. 

After installation of distribution we can approach to installation of TeXstudio editor. Installation 

package is available at page. After installation is possible to start with creation of LaTeX documents. 

By clicking at TeXstudio icon the main window will appear (see Fig. 1), where in upper part is 

located classical main panel with options File, Edit, Tools, etc. On the left hand side of the window it 

can be seen document structure. Document can consists of more parts, between which can be switch 

here. Next in this left panel can be found bookmarks, but also there are located prearranged commands 
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for symbols (Greek, Cyrillic, math, etc.), mathematical operators, brackets, etc. 

In the middle part of the window is opened currently edited document. For illustration in Fig. 1. has 

been chosen presentation from built in template. On the right hand side is pdf view to edited 

presentation.  

The last part is message area located in the bottom of the program window. Message are offers 

information about status of the compilation. It informs user if the compilation run correctly or if there 

is some mistake. If there was a mistake, it will show incorrect row and type of error. 

After the first startup is good to check, if the program found installed distribution of TeX. This will 

prevent from later problems with compilation. It can be checked in Main menu under the 

Options>Configure TeXstudio. It will appear the configuration window where can be found option 

Commands. Here is needed to be checked if under the option LaTeX and PdfLaTeX are inserted 

correct paths. In case there are values set as <unknown>, it is needed to set paths according to manual 

available in Help>User Manual or at official webpage [5], [6]. This problem often occurs when the 

editor is installed before the TeX distribution. This is reason why paths are not set because program 

was not able to find it during installation. 

 

 
Fig. 1  Main window of TeXstudio 

 

III. DOCUMENTS CREATION AND OPENING 

TeXstudio offers couple of option how to create a new document. The first is classic option of 

creating blank document through option File>New. This option is more suitable for advanced users, 

who already know individual commands and used packages. The next option for creating new 

documents is use prepared templates. This option can be found in File>New from Template. In this 

case have user at choice from list of templates for articles, curriculum vitae, books, etc. In these 

templates is created structure of documents but in preamble are not defined any packages (like 

language, encoding) or another details. The most suitable option for newbies in LaTeX is creation of 

new document through the option Quick Start. It is located in main panel under the option Wizards. 

This option is illustrated in the Fig. 2. After the selection of required type of document, in the editor 

part of window is created code which represent selected properties of documents. In case from Fig. 1. 

has been created Beamer presentation also from Wizard option. In the upper part of the code is 

defined type of document beamer through the command \documentclass. In the preamble are 

also used packages by command \usepackage. Packages extend functionality of LaTeX about the 
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large number of different commands. As was said these packages customize text encoding, used 

language, etc. The complete list of packages can be found at webpage [7]. After adding new package 

to preamble, package is automatically downloaded from repositories at the internet. 

Except the creation of new documents is very often needed to open existing documents or templates 

from other sources. Existing document is opened by clicking on icon Open ( ), or classical way 

through File>Open. User then set the path to desired document, that will be automatically loaded in to 

the editor. In case that is needed to save actual document as template for later use, is process trivial. 

User just need to apply option File>Make Template at the currently opened document.  

Compilation of the document is provided by clicking on the icon Compile ( ), in the upper part of 

the code editing area. Before the compilation document has to be saved ( ). Preview of the 

document is provided by clicking at button View ( ). Button Build & View ( ) does everything on 

one go. 

 
Fig. 2  The Quick Start wizard for creation of new documents 

 

IV. BASIC COMMANDS AND TEXT FORMATTING 

All commands in LaTeX are in the following form [2] : 

 

\(name of command) 

 

where (name of command) is a string of letters or in some commands only single character. Be 

careful LaTeX is case-sensitive. 

Very important in this state is mention the enviroments. These are bordered by commands: 

 

\begin{(name of enviroment)} 

 

 

\end{(name of enviroment)} 

 

The code inserted between these two commands is processed in a way, that is specific for a given 

environment. From the Fig. 1 is possible to see, that it was used the environment document and frame 

between them was inserted other commands. 

Basic logical division of the text in to the chapters, sections and subsections is provided by series of 

the following commands: 

 

\chapter{(name of chapter)} 
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\section{(name of section)} 

 

\subsection{(name of subsection)} 

 

This sectioning and all the environments is possible to find in TeXstudio under do option 

LaTeX>Sectioning or LaTeX>Enviroments in the main menu. Here are also located commands for 

edition of size and styles of fonts (LaTeX>Font Sizes/Styles). Basic commands for the font style are 

located in the tool panel on the left hand side of the window with code as well. For example command 

for bold text with icon Boldface ( ), or cursive font  Italics ( ). 

 

V. LABELS AND REFERENCES 

Making of cross-references is very convenient for better orientation in created text. Cross-references 

are created by labels on which we are able to reference later. Label is created by the command 

\label and reference by the command \ref. 

Labels are always „sticked“ after some section, equation or figure on which we will later make 

a reference. Fast insertion of label in TeXstudio can be done by clicking on the button label, located 

directly in the toolbox above the area with the code. Useful keyboard shortcut for creation of the fast 

reference to next label is Ctrl+Alt+R. 

VI. IMAGE INSERTION 

In the beginning was mentioned option Wizards by which is possible to create quick body of the 

document. Except this feature there are located others, one of them is quick image insertion. Fig. 3 

shows possibility of image insertion which can be found in Wizards>Insert Graphics. 

In the upper part of the window from the Fig. 3 can be seen option of the path selection to the 

image, which is desired to be in the document. Further there are located graphic options, like setting 

width and height of the image. In the next area can be set caption of the figure and where the caption 

will be located (above or below the figure). Short caption is the one, which will be shown in the list of 

figures of the document. Long caption will be located above or below the graphic depending on the 

settings. After all the last option is name of the label. Name of the label used to be filled in 

automatically with the name of the inserted image. After clicking on OK button is generated code 

needed for LaTeX. 

 

 
Fig. 3  Insert graphic wizard in TeXstudio 
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VII. EQUATIONS AND TABLES 

Before the explanation of how are the equations inserted in the TeXstudio, is very convenient to 

mention set of tools AMS-LaTeX. This set of tools contain several number of packages, which are used 

for production of advanced typographical tasks [2]. Basic packages from this set are amsmath, 

amsfonts a amssymb. These package is good to load in the preamble of the document, which will 

contain the mathematics. 

Short mathematical expressions, which have to be written in one paragraph, are inserted between 

two symbols $. Symbols $ represent beginning and end of the inline mathematical mode. In TeXstudio 

is possible to highlight some mathematical text and by clicking on the icon Inline math mode ( ), the 

following text will be inserted between two $ symbols. Similarly have to be bordered commands for 

upper and lower index, in case that is needed to have them in one paragraph. Command for upper 

index is generated press down the button Subscript ( ), lower index Superscript ( ). 

In case that is needed to write down some advanced mathematical expressions is more convenient to 

use multiple line mathematical mode, concretely environment called equation*. Generation of the 

command for creation of environment is can be found in main menu, under the option Math>Math 

equations>env equation*. In Math menu is located huge number of mathematical operations, 

functions, symbols and operators that are commonly used in environment equation*. 

Interesting feature is Math Assistant again located in Wizards option (Fig. 4). It is able to generate 

LaTeX code from written down equation to this assistant. In example from Fig. 4 it was written down 

gravitational force formula (yellow area). In the area above has been recognized correct formula from 

written text. 
 

 
Fig. 4. Math Assistant Wizard 

 

From this assistant, after clicking on the button insert, have been generated following command: 

 

${F}_{g}=\frac{G{m}_{1}{m}_{2}}{{r}^{2}}$ 

 

This command really belongs to the written equation and is completely correct for compilation in 

LaTeX. This feature is not used very often, because writing equations with computer mouse is quite 

uncomfortable. But maybe this feature will more appreciate users with touchscreen monitors and 

stylus pen.  

The last demonstration from the TeXstudio editor will be possibility of tables creation. Table 

creation is in LaTeX quite „great science“. For this reason, we will show how we can ease the process 

by using the mentioned editor. Again will be used option Wizard, where will be created table like in 

classical WYSIWYG editore. From this table will be generated code needed for compilation in 

LaTeX. The window shown in the Fig. 5 has been obtained from Wizards>Quick Tabular.  

From the Fig. 4 can be seen, that user will firstly define number of rows and number of columns. 

For each row is possible to set align of the content. Also is possible to merge desired columns or set 

the line which bounding the table, etc. 

Although the Quick Tabular does not provide creation of very advanced tables, it is convenient 

assistant when is needed to quickly create simple table. Similarly, it can help newbies in LaTeX, for 

understanding of basic commands for creation tables.  

After pressing button OK it is generated LaTeX code. For table from Fig. 5 was the code following:  
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\begin{tabular}{||l|c|r||} 

  \hline  

  Col. 1 & Col. 2 & Col. 3 \\  

  \hline  

  542 & 353 & 683 \\  

  \hline  

  783 & 12 & 77 \\  

  \hline  

 \end{tabular} 

 

In present also exists online LaTeX tables generators. One of them is available at following 

webpage [8]. 

 

 
Fig. 5. Quick Tabular wizard in TeXstudio 

 

VIII. CONCLUSION  

This article in short shows fundamentals of work with TeXstudio editor. It is popular because of its 

well-arranged graphical interface, which ease transition to users of WYSIWYG editors to LaTeX. In 

case of some uncertainties about LaTeX, it is very suggested to read through literature [1], which is 

quite straightforward and freely available. For this reason, it was translated to several languages.  
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